problem running DOC2PDF even in the command line

Aug 20, 2009 at 8:19 AM

Hi!

I installed the feature and at first it looked as everything is ok but conversion was not successful. When I read through all the discussins and tried all that things, I finnaly decided to try the Doc2PDF.exe program in the command line.

I can see that the program dosn't work even in the command line. It responds with the following error message in the log file:

 8/20/2009 12:55:26 AM Started
doc2pdf -in c:\convert\drugi.docx -out c:\convert\drugi.pdf -log c:\convert\error.log
The export failed because this feature is not installed.

The file "drugi.docx" is present in the c:\convert\ directory. What could be wrong? I have also tried with the document generated with Word 2003 (doc extension) and the result is the same.

Could someone help me to solve this problem?

Aug 20, 2009 at 8:51 AM

My next attempt on another machine. Command does not work, but I receive another error messsage.

20.8.2009 10:46:20 Started
doc2pdf -in c:\convert\badminton.doc -out c:\convert\drugi.pdf -log c:\convert\error.log
Could not load file or assembly 'Microsoft.Office.Interop.Word, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

On this mchine I have Word 2003. Is this perhaps the reson for this new error message?

Aug 20, 2009 at 9:04 AM

I solved it myself. The reason was that the feature for converting from DOC to PDF was not installed on Word 2007 in my machine. Now it works.

Of course, on other machine it didn't work because Word 2003 does not support conversion from DOC to PDF.